Connection been closed

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Connection been closed

Guilherme Carvalho
hello guys, i am having another problem with my client, everybody connect to RDP fine, but when starts to working, click on start menu, or open the company software the connection close.

What could be this?

Thanks
Reply | Threaded
Open this post in threaded view
|

Re: Connection been closed

vnick
On Wed, Jun 10, 2020 at 11:48 AM Guilherme Carvalho <[hidden email]> wrote:
hello guys, i am having another problem with my client, everybody connect to RDP fine, but when starts to working, click on start menu, or open the company software the connection close.


Are you getting any errors with guacd?  Anything in the logs?

-Nick
Reply | Threaded
Open this post in threaded view
|

Re: Connection been closed

Guilherme Carvalho
Nick, the erros should be on /var/log/tomcat9/catalina.out?

Em qua., 10 de jun. de 2020 às 12:52, Nick Couchman <[hidden email]> escreveu:
On Wed, Jun 10, 2020 at 11:48 AM Guilherme Carvalho <[hidden email]> wrote:
hello guys, i am having another problem with my client, everybody connect to RDP fine, but when starts to working, click on start menu, or open the company software the connection close.


Are you getting any errors with guacd?  Anything in the logs?

-Nick
Reply | Threaded
Open this post in threaded view
|

Re: Connection been closed

Gianluca Renzi
In reply to this post by Guilherme Carvalho
Are you using Ubuntu 18.04 for this Guacamole deployment? I had a similar problem, along with huge memory consumption for every guacd process (more than 1gb each), and the problem was with the freerdp libraries packaged in Ubuntu 18.04. I reinstalled on Debian 10 and now it runs fine with more than 200 simultaneous users (the server has 32 cores and 64gb ram).


Il giorno mer 10 giu 2020 alle 17:48 Guilherme Carvalho <[hidden email]> ha scritto:
hello guys, i am having another problem with my client, everybody connect to RDP fine, but when starts to working, click on start menu, or open the company software the connection close.

What could be this?

Thanks
--

Gianluca Renzi / Network engineer
+39.334.2312307/ [hidden email]

N3tCom Sas
Office: +39.0775.1855155 / Fax: +39.0775.1850188
via F. Brighindi, 26
03100 Frosinone

http://www.n3tcom.com

This e-mail message may contain confidential or legally privileged information and is intended only for the use of the intended recipient(s). Any unauthorized disclosure, dissemination, distribution, copying or the taking of any action in reliance on the information herein is prohibited.

Reply | Threaded
Open this post in threaded view
|

Re: Connection been closed

Charaoui, Jérôme
In reply to this post by Guilherme Carvalho
Hi Guillermo,

My suggestion would be to also check the logs of the company firewall,
if you have one.
I've seen some cases in which remote desktop software can trigger
flooding protections that are implemented in such firewalls.

-- Jerome


Le 20-06-10 à 11 h 48, Guilherme Carvalho a écrit :
> hello guys, i am having another problem with my client, everybody
> connect to RDP fine, but when starts to working, click on start menu,
> or open the company software the connection close.
>
> What could be this?
>
> Thanks



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Connection been closed

Guilherme Carvalho
In reply to this post by Gianluca Renzi
Yes, i am using, Ubuntu 18.04 in this guacamole. i´ll verify to migrate to Debian to test

Em qua., 10 de jun. de 2020 às 12:58, Gianluca Renzi <[hidden email]> escreveu:
Are you using Ubuntu 18.04 for this Guacamole deployment? I had a similar problem, along with huge memory consumption for every guacd process (more than 1gb each), and the problem was with the freerdp libraries packaged in Ubuntu 18.04. I reinstalled on Debian 10 and now it runs fine with more than 200 simultaneous users (the server has 32 cores and 64gb ram).


Il giorno mer 10 giu 2020 alle 17:48 Guilherme Carvalho <[hidden email]> ha scritto:
hello guys, i am having another problem with my client, everybody connect to RDP fine, but when starts to working, click on start menu, or open the company software the connection close.

What could be this?

Thanks
--

Gianluca Renzi / Network engineer
+39.334.2312307/ [hidden email]

N3tCom Sas
Office: +39.0775.1855155 / Fax: +39.0775.1850188
via F. Brighindi, 26
03100 Frosinone

http://www.n3tcom.com

This e-mail message may contain confidential or legally privileged information and is intended only for the use of the intended recipient(s). Any unauthorized disclosure, dissemination, distribution, copying or the taking of any action in reliance on the information herein is prohibited.

Reply | Threaded
Open this post in threaded view
|

Re: Connection been closed

Guilherme Carvalho
In reply to this post by Charaoui, Jérôme
i will ask to the TI of my client verify this, could be this the problem

Em qua., 10 de jun. de 2020 às 13:00, Charaoui, Jérôme <[hidden email]> escreveu:
Hi Guillermo,

My suggestion would be to also check the logs of the company firewall,
if you have one.
I've seen some cases in which remote desktop software can trigger
flooding protections that are implemented in such firewalls.

-- Jerome


Le 20-06-10 à 11 h 48, Guilherme Carvalho a écrit :
> hello guys, i am having another problem with my client, everybody
> connect to RDP fine, but when starts to working, click on start menu,
> or open the company software the connection close.
>
> What could be this?
>
> Thanks



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Connection been closed

Guilherme Carvalho
This is what appears on the catalina.out.

[2020-06-10 14:26:31] [info] 14:26:31.938 [http-nio-8080-exec-4] INFO  o.a.g.tunnel.TunnelRequestService - User "nefro03" connected to connection "45".
[2020-06-10 14:26:32] [info] 14:26:32.365 [http-nio-8080-exec-8] INFO  o.a.g.tunnel.TunnelRequestService - User "nefro03" disconnected from connection "45". Duration: 427 milliseconds
[2020-06-10 14:26:32] [info] Exception in thread "Thread-325" java.lang.IllegalStateException: Message will not be sent because the WebSocket session has been closed
[2020-06-10 14:26:32] [info] #011at org.apache.tomcat.websocket.WsRemoteEndpointImplBase.writeMessagePart(WsRemoteEndpointImplBase.java:425)
[2020-06-10 14:26:32] [info] #011at org.apache.tomcat.websocket.WsRemoteEndpointImplBase.sendMessageBlock(WsRemoteEndpointImplBase.java:309)
[2020-06-10 14:26:32] [info] #011at org.apache.tomcat.websocket.WsRemoteEndpointImplBase.sendMessageBlock(WsRemoteEndpointImplBase.java:250)
[2020-06-10 14:26:32] [info] #011at org.apache.tomcat.websocket.WsRemoteEndpointImplBase.sendString(WsRemoteEndpointImplBase.java:191)
[2020-06-10 14:26:32] [info] #011at org.apache.tomcat.websocket.WsRemoteEndpointBasic.sendText(WsRemoteEndpointBasic.java:37)
[2020-06-10 14:26:32] [info] #011at org.apache.guacamole.websocket.GuacamoleWebSocketTunnelEndpoint.sendInstruction(GuacamoleWebSocketTunnelEndpoint.java:152)
[2020-06-10 14:26:32] [info] #011at org.apache.guacamole.websocket.GuacamoleWebSocketTunnelEndpoint.access$200(GuacamoleWebSocketTunnelEndpoint.java:53)
[2020-06-10 14:26:32] [info] #011at org.apache.guacamole.websocket.GuacamoleWebSocketTunnelEndpoint$2.run(GuacamoleWebSocketTunnelEndpoint.java:253)

Anybody know what could be?

Thanks

Em qua., 10 de jun. de 2020 às 14:28, Guilherme Carvalho <[hidden email]> escreveu:
i will ask to the TI of my client verify this, could be this the problem

Em qua., 10 de jun. de 2020 às 13:00, Charaoui, Jérôme <[hidden email]> escreveu:
Hi Guillermo,

My suggestion would be to also check the logs of the company firewall,
if you have one.
I've seen some cases in which remote desktop software can trigger
flooding protections that are implemented in such firewalls.

-- Jerome


Le 20-06-10 à 11 h 48, Guilherme Carvalho a écrit :
> hello guys, i am having another problem with my client, everybody
> connect to RDP fine, but when starts to working, click on start menu,
> or open the company software the connection close.
>
> What could be this?
>
> Thanks



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Connection been closed

vnick
On Wed, Jun 10, 2020 at 1:40 PM Guilherme Carvalho <[hidden email]> wrote:
This is what appears on the catalina.out.

[2020-06-10 14:26:31] [info] 14:26:31.938 [http-nio-8080-exec-4] INFO  o.a.g.tunnel.TunnelRequestService - User "nefro03" connected to connection "45".
[2020-06-10 14:26:32] [info] 14:26:32.365 [http-nio-8080-exec-8] INFO  o.a.g.tunnel.TunnelRequestService - User "nefro03" disconnected from connection "45". Duration: 427 milliseconds
[2020-06-10 14:26:32] [info] Exception in thread "Thread-325" java.lang.IllegalStateException: Message will not be sent because the WebSocket session has been closed
[2020-06-10 14:26:32] [info] #011at org.apache.tomcat.websocket.WsRemoteEndpointImplBase.writeMessagePart(WsRemoteEndpointImplBase.java:425)
[2020-06-10 14:26:32] [info] #011at org.apache.tomcat.websocket.WsRemoteEndpointImplBase.sendMessageBlock(WsRemoteEndpointImplBase.java:309)
[2020-06-10 14:26:32] [info] #011at org.apache.tomcat.websocket.WsRemoteEndpointImplBase.sendMessageBlock(WsRemoteEndpointImplBase.java:250)
[2020-06-10 14:26:32] [info] #011at org.apache.tomcat.websocket.WsRemoteEndpointImplBase.sendString(WsRemoteEndpointImplBase.java:191)
[2020-06-10 14:26:32] [info] #011at org.apache.tomcat.websocket.WsRemoteEndpointBasic.sendText(WsRemoteEndpointBasic.java:37)
[2020-06-10 14:26:32] [info] #011at org.apache.guacamole.websocket.GuacamoleWebSocketTunnelEndpoint.sendInstruction(GuacamoleWebSocketTunnelEndpoint.java:152)
[2020-06-10 14:26:32] [info] #011at org.apache.guacamole.websocket.GuacamoleWebSocketTunnelEndpoint.access$200(GuacamoleWebSocketTunnelEndpoint.java:53)
[2020-06-10 14:26:32] [info] #011at org.apache.guacamole.websocket.GuacamoleWebSocketTunnelEndpoint$2.run(GuacamoleWebSocketTunnelEndpoint.java:253)

Anybody know what could be?


You need to check syslog - either /var/log/messages, journalctl, or wherever syslog messages are normally logged on your system.  guacd output will be there.

-Nick 
Reply | Threaded
Open this post in threaded view
|

Re: Connection been closed

ivanmarcus
In reply to this post by Guilherme Carvalho

Guilherme,

I see in other posts you're using Ubuntu 18.04?

It may be worth checking what version of FreeRDP you're using (ldconfig -v | grep free). If it's 2.1.1 then you could be running into this problem:

http://apache-guacamole-general-user-mailing-list.2363388.n4.nabble.com/Guacamole-FreeRDP-disconnect-td8575.html

The reason for the problem, and fix/workaround, is included in that thread.


On 11/06/2020 3:48 a.m., Guilherme Carvalho wrote:
hello guys, i am having another problem with my client, everybody connect to RDP fine, but when starts to working, click on start menu, or open the company software the connection close.

What could be this?

Thanks

Reply | Threaded
Open this post in threaded view
|

Re: Connection been closed

Guilherme Carvalho
Thanks Ivan,

i replacace the 2.1.1 version to the 2.0.0 version of freerdp, now i´ll wait my client to test the connections tomorrow.

thanks

Em qua., 10 de jun. de 2020 às 21:10, ivanmarcus <[hidden email]> escreveu:

Guilherme,

I see in other posts you're using Ubuntu 18.04?

It may be worth checking what version of FreeRDP you're using (ldconfig -v | grep free). If it's 2.1.1 then you could be running into this problem:

http://apache-guacamole-general-user-mailing-list.2363388.n4.nabble.com/Guacamole-FreeRDP-disconnect-td8575.html

The reason for the problem, and fix/workaround, is included in that thread.


On 11/06/2020 3:48 a.m., Guilherme Carvalho wrote:
hello guys, i am having another problem with my client, everybody connect to RDP fine, but when starts to working, click on start menu, or open the company software the connection close.

What could be this?

Thanks