Guacamole FreeRDP disconnect

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

Guacamole FreeRDP disconnect

Neumen - Juan Prigoshin

Hi, we have using Guacamole for about 2 months. We use a user-mapping auth.

Everything Works fine.

Today, the users cannot use RDP for conections.

Login ok, Windows Login ok. 15 secs later, disconnect.

 

Any help what i need see?

The syslog shows no errors, but 4 diferent W7 machines shows the same behavior.

The machine disconnect when we click in Start Menu.

 

I have disabled remote disk, remote printing, same problem.

 

Any help??

 

Juan

 

 

 

wla
Reply | Threaded
Open this post in threaded view
|

AW: Guacamole FreeRDP disconnect

wla

I had same(?) issue today.

Recompile guacd and restart it and report the result.

 

Do you have “Ubuntu 18.5.4”?

Maybe the libraries have been updated?

 

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 14:34
An: [hidden email]
Betreff: Guacamole FreeRDP disconnect

 

Hi, we have using Guacamole for about 2 months. We use a user-mapping auth.

Everything Works fine.

Today, the users cannot use RDP for conections.

Login ok, Windows Login ok. 15 secs later, disconnect.

 

Any help what i need see?

The syslog shows no errors, but 4 diferent W7 machines shows the same behavior.

The machine disconnect when we click in Start Menu.

 

I have disabled remote disk, remote printing, same problem.

 

Any help??

 

Juan

 

 

 

wla
Reply | Threaded
Open this post in threaded view
|

AW: Guacamole FreeRDP disconnect

wla

It should say "Ubuntu 18.04.4”

 

Von: Walter Laub <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:04
An: [hidden email]
Betreff: AW: Guacamole FreeRDP disconnect

 

I had same(?) issue today.

Recompile guacd and restart it and report the result.

 

Do you have “Ubuntu 18.5.4”?

Maybe the libraries have been updated?

 

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 14:34
An: [hidden email]
Betreff: Guacamole FreeRDP disconnect

 

Hi, we have using Guacamole for about 2 months. We use a user-mapping auth.

Everything Works fine.

Today, the users cannot use RDP for conections.

Login ok, Windows Login ok. 15 secs later, disconnect.

 

Any help what i need see?

The syslog shows no errors, but 4 diferent W7 machines shows the same behavior.

The machine disconnect when we click in Start Menu.

 

I have disabled remote disk, remote printing, same problem.

 

Any help??

 

Juan

 

 

 

Reply | Threaded
Open this post in threaded view
|

RE: Guacamole FreeRDP disconnect

Neumen - Juan Prigoshin

Same Ubuntu. With recompile the problema dissapear?

 

 

De: Walter Laub [mailto:[hidden email]]
Enviado el: martes, 02 de junio de 2020 10:06 a.m.
Para: [hidden email]
Asunto: AW: Guacamole FreeRDP disconnect

 

It should say "Ubuntu 18.04.4”

 

Von: Walter Laub <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:04
An: [hidden email]
Betreff: AW: Guacamole FreeRDP disconnect

 

I had same(?) issue today.

Recompile guacd and restart it and report the result.

 

Do you have “Ubuntu 18.5.4”?

Maybe the libraries have been updated?

 

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 14:34
An: [hidden email]
Betreff: Guacamole FreeRDP disconnect

 

Hi, we have using Guacamole for about 2 months. We use a user-mapping auth.

Everything Works fine.

Today, the users cannot use RDP for conections.

Login ok, Windows Login ok. 15 secs later, disconnect.

 

Any help what i need see?

The syslog shows no errors, but 4 diferent W7 machines shows the same behavior.

The machine disconnect when we click in Start Menu.

 

I have disabled remote disk, remote printing, same problem.

 

Any help??

 

Juan

 

 

 

wla
Reply | Threaded
Open this post in threaded view
|

AW: Guacamole FreeRDP disconnect

wla

Yeah, in my installation.

In the meantime, I checked autoupdate, which installed an update of the freerdp2 libraries. This caused the problem, I think.

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:35
An: [hidden email]
Betreff: RE: Guacamole FreeRDP disconnect

 

Same Ubuntu. With recompile the problema dissapear?

 

 

De: Walter Laub [[hidden email]]
Enviado el: martes, 02 de junio de 2020 10:06 a.m.
Para: [hidden email]
Asunto: AW: Guacamole FreeRDP disconnect

 

It should say "Ubuntu 18.04.4”

 

Von: Walter Laub <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:04
An: [hidden email]
Betreff: AW: Guacamole FreeRDP disconnect

 

I had same(?) issue today.

Recompile guacd and restart it and report the result.

 

Do you have “Ubuntu 18.5.4”?

Maybe the libraries have been updated?

 

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 14:34
An: [hidden email]
Betreff: Guacamole FreeRDP disconnect

 

Hi, we have using Guacamole for about 2 months. We use a user-mapping auth.

Everything Works fine.

Today, the users cannot use RDP for conections.

Login ok, Windows Login ok. 15 secs later, disconnect.

 

Any help what i need see?

The syslog shows no errors, but 4 diferent W7 machines shows the same behavior.

The machine disconnect when we click in Start Menu.

 

I have disabled remote disk, remote printing, same problem.

 

Any help??

 

Juan

 

 

 

Reply | Threaded
Open this post in threaded view
|

RE: Guacamole FreeRDP disconnect

Neumen - Juan Prigoshin

 

2020-06-02 06:03:38 status unpacked libfreerdp-shadow-subsystem2-2:amd64 2.1.1+dfsg1-0ubuntu0.18.04.1

2020-06-02 06:03:38 status half-configured libfreerdp-shadow-subsystem2-2:amd64 2.1.1+dfsg1-0ubuntu0.18.04.1

2020-06-02 06:03:38 status installed libfreerdp-shadow-subsystem2-2:amd64 2.1.1+dfsg1-0ubuntu0.18.04.1

2020-06-02 06:03:38 configure freerdp2-dev:amd64 2.1.1+dfsg1-0ubuntu0.18.04.1 <ninguna>

2020-06-02 06:03:38 status unpacked freerdp2-dev:amd64 2.1.1+dfsg1-0ubuntu0.18.04.1

2020-06-02 06:03:39 status half-configured freerdp2-dev:amd64 2.1.1+dfsg1-0ubuntu0.18.04.1

2020-06-02 06:03:39 status installed freerdp2-dev:amd64 2.1.1+dfsg1-0ubuntu0.18.04.1

 

You have it rigth!!! Auto update 5 hours ago! Thanks, i will recompile!

 

 

De: Walter Laub [mailto:[hidden email]]
Enviado el: martes, 02 de junio de 2020 10:38 a.m.
Para: [hidden email]
Asunto: AW: Guacamole FreeRDP disconnect

 

Yeah, in my installation.

In the meantime, I checked autoupdate, which installed an update of the freerdp2 libraries. This caused the problem, I think.

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:35
An: [hidden email]
Betreff: RE: Guacamole FreeRDP disconnect

 

Same Ubuntu. With recompile the problema dissapear?

 

 

De: Walter Laub [[hidden email]]
Enviado el: martes, 02 de junio de 2020 10:06 a.m.
Para: [hidden email]
Asunto: AW: Guacamole FreeRDP disconnect

 

It should say "Ubuntu 18.04.4”

 

Von: Walter Laub <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:04
An: [hidden email]
Betreff: AW: Guacamole FreeRDP disconnect

 

I had same(?) issue today.

Recompile guacd and restart it and report the result.

 

Do you have “Ubuntu 18.5.4”?

Maybe the libraries have been updated?

 

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 14:34
An: [hidden email]
Betreff: Guacamole FreeRDP disconnect

 

Hi, we have using Guacamole for about 2 months. We use a user-mapping auth.

Everything Works fine.

Today, the users cannot use RDP for conections.

Login ok, Windows Login ok. 15 secs later, disconnect.

 

Any help what i need see?

The syslog shows no errors, but 4 diferent W7 machines shows the same behavior.

The machine disconnect when we click in Start Menu.

 

I have disabled remote disk, remote printing, same problem.

 

Any help??

 

Juan

 

 

 

Reply | Threaded
Open this post in threaded view
|

Re: Guacamole FreeRDP disconnect

Ghost_Knight
In reply to this post by wla
What version Guacamole are you using?  Have you updated to 1.1.0 recently?

For logging, I would look at the guacamole-server piece and try and pull some context logs from there and post those on this thread :)

On Tue, Jun 2, 2020 at 9:38 AM Walter Laub <[hidden email]> wrote:

Yeah, in my installation.

In the meantime, I checked autoupdate, which installed an update of the freerdp2 libraries. This caused the problem, I think.

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:35
An: [hidden email]
Betreff: RE: Guacamole FreeRDP disconnect

 

Same Ubuntu. With recompile the problema dissapear?

 

 

De: Walter Laub [[hidden email]]
Enviado el: martes, 02 de junio de 2020 10:06 a.m.
Para: [hidden email]
Asunto: AW: Guacamole FreeRDP disconnect

 

It should say "Ubuntu 18.04.4”

 

Von: Walter Laub <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:04
An: [hidden email]
Betreff: AW: Guacamole FreeRDP disconnect

 

I had same(?) issue today.

Recompile guacd and restart it and report the result.

 

Do you have “Ubuntu 18.5.4”?

Maybe the libraries have been updated?

 

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 14:34
An: [hidden email]
Betreff: Guacamole FreeRDP disconnect

 

Hi, we have using Guacamole for about 2 months. We use a user-mapping auth.

Everything Works fine.

Today, the users cannot use RDP for conections.

Login ok, Windows Login ok. 15 secs later, disconnect.

 

Any help what i need see?

The syslog shows no errors, but 4 diferent W7 machines shows the same behavior.

The machine disconnect when we click in Start Menu.

 

I have disabled remote disk, remote printing, same problem.

 

Any help??

 

Juan

 

 

 

Reply | Threaded
Open this post in threaded view
|

Re: Guacamole FreeRDP disconnect

Tushar Jain
Yes there was an issue with 1.1.0 and Windows , where windows rdp session was disconnected automatically after some time due to missing handshake between freerdp2 and windows. This issue was resolved in the github version which you can download and build. I had done that but an old CAPS Key problem re-appeared. This was about a month back and not sure of the current status. Eagerly waiting for 1.2.0 in anticipation that these issues will be resolved.




On Tue, Jun 2, 2020 at 7:26 PM Tim Worcester <[hidden email]> wrote:
What version Guacamole are you using?  Have you updated to 1.1.0 recently?

For logging, I would look at the guacamole-server piece and try and pull some context logs from there and post those on this thread :)

On Tue, Jun 2, 2020 at 9:38 AM Walter Laub <[hidden email]> wrote:

Yeah, in my installation.

In the meantime, I checked autoupdate, which installed an update of the freerdp2 libraries. This caused the problem, I think.

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:35
An: [hidden email]
Betreff: RE: Guacamole FreeRDP disconnect

 

Same Ubuntu. With recompile the problema dissapear?

 

 

De: Walter Laub [[hidden email]]
Enviado el: martes, 02 de junio de 2020 10:06 a.m.
Para: [hidden email]
Asunto: AW: Guacamole FreeRDP disconnect

 

It should say "Ubuntu 18.04.4”

 

Von: Walter Laub <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:04
An: [hidden email]
Betreff: AW: Guacamole FreeRDP disconnect

 

I had same(?) issue today.

Recompile guacd and restart it and report the result.

 

Do you have “Ubuntu 18.5.4”?

Maybe the libraries have been updated?

 

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 14:34
An: [hidden email]
Betreff: Guacamole FreeRDP disconnect

 

Hi, we have using Guacamole for about 2 months. We use a user-mapping auth.

Everything Works fine.

Today, the users cannot use RDP for conections.

Login ok, Windows Login ok. 15 secs later, disconnect.

 

Any help what i need see?

The syslog shows no errors, but 4 diferent W7 machines shows the same behavior.

The machine disconnect when we click in Start Menu.

 

I have disabled remote disk, remote printing, same problem.

 

Any help??

 

Juan

 

 

 


Disclaimer: This message and any attachment may contain confidential, proprietary information and is intended only for the individual named. If you are not the original intended recipient and have erroneously received this message, you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. Hitachi MGRM Net E-mail transmission cannot be guaranteed to be secure or error-free as information could be intercepted, corrupted, lost, destroyed, arrive late or incomplete, or contain viruses. Hitachi MGRM Net therefore does not accept liability for any errors or omissions in the contents of this message, which arise as a result of e-mail transmission. If verification is required, please request a hard-copy version. Hitachi MGRM Net Ltd, C - 6/5, Safdarjung Development Area, New Delhi - 110016, India

'Please consider the environment before printing this e-mail'.
Reply | Threaded
Open this post in threaded view
|

Re: Guacamole FreeRDP disconnect

ivanmarcus

I ran into this issue just now.

The problem manifested itself in an orange screen being presented to users, and disconnection either immediately upon login, or shortly after. The only change to the system was that freerdp had updated from 2.0.0 to 2.1.1

For anyone wanting the quick fix (Ubuntu 18.04), this is what I did:

ldconfig -v | grep libfree (show current version)
apt install aptitude (it dealt with dependencies much better)
apt-cache showpkg freerdp2-dev (show packages available)
aptitude install freerdp2-dev=2.0.0~git20170725.1.1648deb+dfsg1-7 (choose and [re]install 2.0.0)
ldconfig -v | grep libfree (check correct package installed)

This has been reported elsewhere and Mike has suggested rebuilding guacamole-server should also deal with it, as it needs to be compiled against a changed version of freerdp.

For various reasons I didn't do that (production server and needed to get going asap), so at this stage I can't say for sure that recompiling does resolve the problem. However it would probably be the best resolution as you would then be using the later version of freerdp, which should deal with one or two other issues (such as disconnect on right-click of start menu etc).


On 3/06/2020 2:19 a.m., Tushar Jain wrote:
Yes there was an issue with 1.1.0 and Windows , where windows rdp session was disconnected automatically after some time due to missing handshake between freerdp2 and windows. This issue was resolved in the github version which you can download and build. I had done that but an old CAPS Key problem re-appeared. This was about a month back and not sure of the current status. Eagerly waiting for 1.2.0 in anticipation that these issues will be resolved.




On Tue, Jun 2, 2020 at 7:26 PM Tim Worcester <[hidden email]> wrote:
What version Guacamole are you using?  Have you updated to 1.1.0 recently?

For logging, I would look at the guacamole-server piece and try and pull some context logs from there and post those on this thread :)

On Tue, Jun 2, 2020 at 9:38 AM Walter Laub <[hidden email]> wrote:

Yeah, in my installation.

In the meantime, I checked autoupdate, which installed an update of the freerdp2 libraries. This caused the problem, I think.

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:35
An: [hidden email]
Betreff: RE: Guacamole FreeRDP disconnect

 

Same Ubuntu. With recompile the problema dissapear?

 

 

De: Walter Laub [[hidden email]]
Enviado el: martes, 02 de junio de 2020 10:06 a.m.
Para: [hidden email]
Asunto: AW: Guacamole FreeRDP disconnect

 

It should say "Ubuntu 18.04.4”

 

Von: Walter Laub <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:04
An: [hidden email]
Betreff: AW: Guacamole FreeRDP disconnect

 

I had same(?) issue today.

Recompile guacd and restart it and report the result.

 

Do you have “Ubuntu 18.5.4”?

Maybe the libraries have been updated?

 

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 14:34
An: [hidden email]
Betreff: Guacamole FreeRDP disconnect

 

Hi, we have using Guacamole for about 2 months. We use a user-mapping auth.

Everything Works fine.

Today, the users cannot use RDP for conections.

Login ok, Windows Login ok. 15 secs later, disconnect.

 

Any help what i need see?

The syslog shows no errors, but 4 diferent W7 machines shows the same behavior.

The machine disconnect when we click in Start Menu.

 

I have disabled remote disk, remote printing, same problem.

 

Any help??

 

Juan

 

 

 


Disclaimer: This message and any attachment may contain confidential, proprietary information and is intended only for the individual named. If you are not the original intended recipient and have erroneously received this message, you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. Hitachi MGRM Net E-mail transmission cannot be guaranteed to be secure or error-free as information could be intercepted, corrupted, lost, destroyed, arrive late or incomplete, or contain viruses. Hitachi MGRM Net therefore does not accept liability for any errors or omissions in the contents of this message, which arise as a result of e-mail transmission. If verification is required, please request a hard-copy version. Hitachi MGRM Net Ltd, C - 6/5, Safdarjung Development Area, New Delhi - 110016, India

'Please consider the environment before printing this e-mail'.

Reply | Threaded
Open this post in threaded view
|

Re: Guacamole FreeRDP disconnect

ivanmarcus

Updating with some further information:

A recompile of Guacamole server did *not* address the issue for me. Please let us know if it has for you.

After running a few tests it seems the issue *may* not be present when connecting to Win10 machines. This was a small test sample however - if you have the same issue with Win10 please tell us.

Symptoms may vary connecting to Win7 machines - could be instant disconnect, disconnect when left-click start menu, disconnect at other random times, colour issues if using 32-bit colour, and maybe others.

For the moment I have taken the route to disable auto-upgrade (apt-get remove unattended-upgrades) so that the previous version of FreeRDP(2.0.0) remains in place and the issue doesn't re-appear overnight.


On 4/06/2020 10:29 a.m., ivanmarcus wrote:

I ran into this issue just now.

The problem manifested itself in an orange screen being presented to users, and disconnection either immediately upon login, or shortly after. The only change to the system was that freerdp had updated from 2.0.0 to 2.1.1

For anyone wanting the quick fix (Ubuntu 18.04), this is what I did:

ldconfig -v | grep libfree (show current version)
apt install aptitude (it dealt with dependencies much better)
apt-cache showpkg freerdp2-dev (show packages available)
aptitude install freerdp2-dev=2.0.0~git20170725.1.1648deb+dfsg1-7 (choose and [re]install 2.0.0)
ldconfig -v | grep libfree (check correct package installed)

This has been reported elsewhere and Mike has suggested rebuilding guacamole-server should also deal with it, as it needs to be compiled against a changed version of freerdp.

For various reasons I didn't do that (production server and needed to get going asap), so at this stage I can't say for sure that recompiling does resolve the problem. However it would probably be the best resolution as you would then be using the later version of freerdp, which should deal with one or two other issues (such as disconnect on right-click of start menu etc).


On 3/06/2020 2:19 a.m., Tushar Jain wrote:
Yes there was an issue with 1.1.0 and Windows , where windows rdp session was disconnected automatically after some time due to missing handshake between freerdp2 and windows. This issue was resolved in the github version which you can download and build. I had done that but an old CAPS Key problem re-appeared. This was about a month back and not sure of the current status. Eagerly waiting for 1.2.0 in anticipation that these issues will be resolved.




On Tue, Jun 2, 2020 at 7:26 PM Tim Worcester <[hidden email]> wrote:
What version Guacamole are you using?  Have you updated to 1.1.0 recently?

For logging, I would look at the guacamole-server piece and try and pull some context logs from there and post those on this thread :)

On Tue, Jun 2, 2020 at 9:38 AM Walter Laub <[hidden email]> wrote:

Yeah, in my installation.

In the meantime, I checked autoupdate, which installed an update of the freerdp2 libraries. This caused the problem, I think.

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:35
An: [hidden email]
Betreff: RE: Guacamole FreeRDP disconnect

 

Same Ubuntu. With recompile the problema dissapear?

 

 

De: Walter Laub [[hidden email]]
Enviado el: martes, 02 de junio de 2020 10:06 a.m.
Para: [hidden email]
Asunto: AW: Guacamole FreeRDP disconnect

 

It should say "Ubuntu 18.04.4”

 

Von: Walter Laub <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:04
An: [hidden email]
Betreff: AW: Guacamole FreeRDP disconnect

 

I had same(?) issue today.

Recompile guacd and restart it and report the result.

 

Do you have “Ubuntu 18.5.4”?

Maybe the libraries have been updated?

 

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 14:34
An: [hidden email]
Betreff: Guacamole FreeRDP disconnect

 

Hi, we have using Guacamole for about 2 months. We use a user-mapping auth.

Everything Works fine.

Today, the users cannot use RDP for conections.

Login ok, Windows Login ok. 15 secs later, disconnect.

 

Any help what i need see?

The syslog shows no errors, but 4 diferent W7 machines shows the same behavior.

The machine disconnect when we click in Start Menu.

 

I have disabled remote disk, remote printing, same problem.

 

Any help??

 

Juan

 

 

 


Disclaimer: This message and any attachment may contain confidential, proprietary information and is intended only for the individual named. If you are not the original intended recipient and have erroneously received this message, you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. Hitachi MGRM Net E-mail transmission cannot be guaranteed to be secure or error-free as information could be intercepted, corrupted, lost, destroyed, arrive late or incomplete, or contain viruses. Hitachi MGRM Net therefore does not accept liability for any errors or omissions in the contents of this message, which arise as a result of e-mail transmission. If verification is required, please request a hard-copy version. Hitachi MGRM Net Ltd, C - 6/5, Safdarjung Development Area, New Delhi - 110016, India

'Please consider the environment before printing this e-mail'.


Reply | Threaded
Open this post in threaded view
|

Re: Guacamole FreeRDP disconnect

mjumper
Administrator
On Wed, Jun 3, 2020, 22:16 ivanmarcus <[hidden email]> wrote:

Updating with some further information:

A recompile of Guacamole server did *not* address the issue for me. Please let us know if it has for you.

After running a few tests it seems the issue *may* not be present when connecting to Win10 machines. This was a small test sample however - if you have the same issue with Win10 please tell us.

Symptoms may vary connecting to Win7 machines - could be instant disconnect, disconnect when left-click start menu, disconnect at other random times, colour issues if using 32-bit colour, and maybe others.


Some of the above sound like regressions that have already been addressed on the "staging/1.2.0" branch, in particular the various flavors of disconnect.

The odd colors, on the other hand ... If this only occurs with the latest release of FreeRDP, this is concerning. It suggests that the internals of the color conversation functions provided by the library have changed such that the byte order is incorrect in certain cases.

- Mike

wla
Reply | Threaded
Open this post in threaded view
|

AW: Guacamole FreeRDP disconnect

wla

Here a recompile solved the problem.
But we only have Win10 clients.

 

Von: Mike Jumper <[hidden email]>
Gesendet: Donnerstag, 4. Juni 2020 08:38
An: [hidden email]
Betreff: Re: Guacamole FreeRDP disconnect

 

On Wed, Jun 3, 2020, 22:16 ivanmarcus <[hidden email]> wrote:

Updating with some further information:

A recompile of Guacamole server did *not* address the issue for me. Please let us know if it has for you.

After running a few tests it seems the issue *may* not be present when connecting to Win10 machines. This was a small test sample however - if you have the same issue with Win10 please tell us.

Symptoms may vary connecting to Win7 machines - could be instant disconnect, disconnect when left-click start menu, disconnect at other random times, colour issues if using 32-bit colour, and maybe others.

 

Some of the above sound like regressions that have already been addressed on the "staging/1.2.0" branch, in particular the various flavors of disconnect.

 

The odd colors, on the other hand ... If this only occurs with the latest release of FreeRDP, this is concerning. It suggests that the internals of the color conversation functions provided by the library have changed such that the byte order is incorrect in certain cases.

 

- Mike

 

Reply | Threaded
Open this post in threaded view
|

Re: Guacamole FreeRDP disconnect

ivanmarcus
In reply to this post by mjumper

FYI I attach an example of the login screen to a 'faulty' connection.

I realise it's a bit small, but you get the idea. The degree of orange varies, in this instance there's still a small section of the correct green (top left), in other cases there's more of the green - but it usually gets eaten up by the orange in time.

The orange persists within the connection, however it's not a mask or screen as I first thought - it appears to be when translating certain colours, and seems to be consistent. I expect this fits in with your thoughts on the issue(?).


On 4/06/2020 6:37 p.m., Mike Jumper wrote:
On Wed, Jun 3, 2020, 22:16 ivanmarcus [hidden email] wrote:

Updating with some further information:

A recompile of Guacamole server did *not* address the issue for me. Please let us know if it has for you.

After running a few tests it seems the issue *may* not be present when connecting to Win10 machines. This was a small test sample however - if you have the same issue with Win10 please tell us.

Symptoms may vary connecting to Win7 machines - could be instant disconnect, disconnect when left-click start menu, disconnect at other random times, colour issues if using 32-bit colour, and maybe others.


Some of the above sound like regressions that have already been addressed on the "staging/1.2.0" branch, in particular the various flavors of disconnect.

The odd colors, on the other hand ... If this only occurs with the latest release of FreeRDP, this is concerning. It suggests that the internals of the color conversation functions provided by the library have changed such that the byte order is incorrect in certain cases.

- Mike




---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Screenshot_2020-06-04_18-50-51.png (3K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

RE: Guacamole FreeRDP disconnect

Neumen - Juan Prigoshin
In reply to this post by ivanmarcus

The recompile did not solve the problem for me. The problems in W7 are the same you relate. We dont use W10 for RDP.

I will test your solution and reach to you with results.

Thanks very much.

 

 

De: ivanmarcus [mailto:[hidden email]]
Enviado el: jueves, 04 de junio de 2020 02:16 a.m.
Para: [hidden email]
Asunto: Re: Guacamole FreeRDP disconnect

 

Updating with some further information:

A recompile of Guacamole server did *not* address the issue for me. Please let us know if it has for you.

After running a few tests it seems the issue *may* not be present when connecting to Win10 machines. This was a small test sample however - if you have the same issue with Win10 please tell us.

Symptoms may vary connecting to Win7 machines - could be instant disconnect, disconnect when left-click start menu, disconnect at other random times, colour issues if using 32-bit colour, and maybe others.

For the moment I have taken the route to disable auto-upgrade (apt-get remove unattended-upgrades) so that the previous version of FreeRDP(2.0.0) remains in place and the issue doesn't re-appear overnight.

 

On 4/06/2020 10:29 a.m., ivanmarcus wrote:

I ran into this issue just now.

The problem manifested itself in an orange screen being presented to users, and disconnection either immediately upon login, or shortly after. The only change to the system was that freerdp had updated from 2.0.0 to 2.1.1

For anyone wanting the quick fix (Ubuntu 18.04), this is what I did:

ldconfig -v | grep libfree (show current version)
apt install aptitude (it dealt with dependencies much better)
apt-cache showpkg freerdp2-dev (show packages available)
aptitude install freerdp2-dev=2.0.0~git20170725.1.1648deb+dfsg1-7 (choose and [re]install 2.0.0)
ldconfig -v | grep libfree (check correct package installed)

This has been reported elsewhere and Mike has suggested rebuilding guacamole-server should also deal with it, as it needs to be compiled against a changed version of freerdp.

For various reasons I didn't do that (production server and needed to get going asap), so at this stage I can't say for sure that recompiling does resolve the problem. However it would probably be the best resolution as you would then be using the later version of freerdp, which should deal with one or two other issues (such as disconnect on right-click of start menu etc).

 

On 3/06/2020 2:19 a.m., Tushar Jain wrote:

Yes there was an issue with 1.1.0 and Windows , where windows rdp session was disconnected automatically after some time due to missing handshake between freerdp2 and windows. This issue was resolved in the github version which you can download and build. I had done that but an old CAPS Key problem re-appeared. This was about a month back and not sure of the current status. Eagerly waiting for 1.2.0 in anticipation that these issues will be resolved.

 

 

 

 

On Tue, Jun 2, 2020 at 7:26 PM Tim Worcester <[hidden email]> wrote:

What version Guacamole are you using?  Have you updated to 1.1.0 recently?

 

For logging, I would look at the guacamole-server piece and try and pull some context logs from there and post those on this thread :)

 

On Tue, Jun 2, 2020 at 9:38 AM Walter Laub <[hidden email]> wrote:

Yeah, in my installation.

In the meantime, I checked autoupdate, which installed an update of the freerdp2 libraries. This caused the problem, I think.

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:35
An: [hidden email]
Betreff: RE: Guacamole FreeRDP disconnect

 

Same Ubuntu. With recompile the problema dissapear?

 

 

De: Walter Laub [[hidden email]]
Enviado el: martes, 02 de junio de 2020 10:06 a.m.
Para: [hidden email]
Asunto: AW: Guacamole FreeRDP disconnect

 

It should say "Ubuntu 18.04.4”

 

Von: Walter Laub <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 15:04
An: [hidden email]
Betreff: AW: Guacamole FreeRDP disconnect

 

I had same(?) issue today.

Recompile guacd and restart it and report the result.

 

Do you have “Ubuntu 18.5.4”?

Maybe the libraries have been updated?

 

 

Von: Neumen - Juan Prigoshin <[hidden email]>
Gesendet: Dienstag, 2. Juni 2020 14:34
An: [hidden email]
Betreff: Guacamole FreeRDP disconnect

 

Hi, we have using Guacamole for about 2 months. We use a user-mapping auth.

Everything Works fine.

Today, the users cannot use RDP for conections.

Login ok, Windows Login ok. 15 secs later, disconnect.

 

Any help what i need see?

The syslog shows no errors, but 4 diferent W7 machines shows the same behavior.

The machine disconnect when we click in Start Menu.

 

I have disabled remote disk, remote printing, same problem.

 

Any help??

 

Juan

 

 

 

 

Disclaimer: This message and any attachment may contain confidential, proprietary information and is intended only for the individual named. If you are not the original intended recipient and have erroneously received this message, you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. Hitachi MGRM Net E-mail transmission cannot be guaranteed to be secure or error-free as information could be intercepted, corrupted, lost, destroyed, arrive late or incomplete, or contain viruses. Hitachi MGRM Net therefore does not accept liability for any errors or omissions in the contents of this message, which arise as a result of e-mail transmission. If verification is required, please request a hard-copy version. Hitachi MGRM Net Ltd, C - 6/5, Safdarjung Development Area, New Delhi - 110016, India

 

'Please consider the environment before printing this e-mail'.