Guacamole "protocol is not installed"

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Guacamole "protocol is not installed"

Brian Petr
I just installed Guacamole from apt-get on Lubuntu 17.04 (new VM I just stood up), and have included libraries for all 3 main protocols (SSH, VNC, RDP). I am able to login to the WebUI, but I am unable to use any of my connections. Logs show "Support for selected protocol is not installed" whether I use ssh, vnc, or rdp.

Thank you
Reply | Threaded
Open this post in threaded view
|

Re: Guacamole "protocol is not installed"

vnick
Brian,
What version of Guacamole gets installed?  If my searches are correct, the versions of Guacamole available in the Ubuntu repositories are 0.9.9 and 0.8.3 - very old versions of Guacamole.  You probably want to try downloading the source and installing following the build instructions:


Alternatively I believe the EPEL repository has relatively recent versions of Guacamole, so if you try CentOS or RHEL you might have better success with a recent-ish package-based install.

-Nick

On Thu, Oct 12, 2017 at 11:59 AM, Brian Petr <[hidden email]> wrote:
I just installed Guacamole from apt-get on Lubuntu 17.04 (new VM I just stood up), and have included libraries for all 3 main protocols (SSH, VNC, RDP). I am able to login to the WebUI, but I am unable to use any of my connections. Logs show "Support for selected protocol is not installed" whether I use ssh, vnc, or rdp.

Thank you

Reply | Threaded
Open this post in threaded view
|

Re: Guacamole "protocol is not installed"

Brian Petr
Silly Ubuntu. That did the trick. Thank you!

On Thu, Oct 12, 2017 at 12:05 PM, Nick Couchman <[hidden email]> wrote:
Brian,
What version of Guacamole gets installed?  If my searches are correct, the versions of Guacamole available in the Ubuntu repositories are 0.9.9 and 0.8.3 - very old versions of Guacamole.  You probably want to try downloading the source and installing following the build instructions:


Alternatively I believe the EPEL repository has relatively recent versions of Guacamole, so if you try CentOS or RHEL you might have better success with a recent-ish package-based install.

-Nick

On Thu, Oct 12, 2017 at 11:59 AM, Brian Petr <[hidden email]> wrote:
I just installed Guacamole from apt-get on Lubuntu 17.04 (new VM I just stood up), and have included libraries for all 3 main protocols (SSH, VNC, RDP). I am able to login to the WebUI, but I am unable to use any of my connections. Logs show "Support for selected protocol is not installed" whether I use ssh, vnc, or rdp.

Thank you