Left Click Not Working Hyper-V Server 2016

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Left Click Not Working Hyper-V Server 2016

Al Gore
This post has NOT been accepted by the mailing list yet.
This post was updated on .
Hello,

I would like to thank the fantastic developers that provide their hard work to the public for free! I use a custom implementation of Guacamole at work to provide a training environment for my division. It works flawlessly to proxy through Hyper-V server 2012R2 and access VMs.

At home, I run Server 2016 as my hypervisor. Unfortunately, I have been experiencing a strange issue where the left click on the mouse does not work. All other functionality is fine. I can right-click and use the entire keyboard.

So far I have tried multiple installations of both Guacamole 0.9.9 and 0.9.10, used both the default servlet and a custom built servlet (following the guide in Chapter 19), messed around extensively with backend configuration and changing items in the client side scripts, and tried several different browsers (IE, edge, Chrome, FF, Vivaldi).

The symptoms seem to indicate an issue with an event listener or something on the client side, but the same exact built works just fine at work on Server 2012R2. Really, the only variable is the version of Windows Server being used.

I am using Ubuntu 16.04 to run guacd. I have run apt update && apt upgrade.

There doesn't appear to be any strange log entries relating to the issue in syslog or catalina.out. Logs indicate that everything is working normally. I get some script errors when I debug in the browser as follows, but I see similar errors at work (and it works there):



Sorry for the lengthy message, thanks again for what you do!


EDIT:

One last thing I forgot to include: I am using the no-auth plugin for authentication. There is no authentication. Here is my config (it connects and displays fine, just no left click):
    <config name="Name" protocol="rdp">
            <param name="hostname" value="hyperv2016.domain.com" />
            <param name="port" value="2179" />
            <param name="password" value="pass/>
            <param name="username" value="user" />
            <param name="domain" value="domain.com" />
            <param name="security" value="any" />
            <param name="ignore-cert" value="true"/>
            <param name="preconnection-blob" value="PCB" />
    </config>