Problem with backspace on AIX 7

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem with backspace on AIX 7

Mark van den Boogaard
Hello all,

We connect to a AIX version 7 with guacamole using the SSH-protocol. When using the backspace it does not show it on the screen. It will do the actually handling, but it is not shown on the screen. The letter is stil on the screen and the cursor didn't move but when pressing "enter" the letter is not in the action. 
Example running "ls" with typo corrected


When we connect to the same server with guacamole using the Telnet-protocol it is just working fine. When connecting directly without guacamole using the SSH-protocol it is also working fine. 

We prefer SSH because telnet does not automatically log in on this machine and the file-transfer we need.

Does anybody has an idea how to solve this?

-- 
Met vriendelijke groet / with kind regards,

Mark van den Boogaard

Reply | Threaded
Open this post in threaded view
|

Re: Problem with backspace on AIX 7

David Landry

Can you reproduce the problem by SSHing in directly? Without Guacamole?


On Fri, Dec 9, 2016, 4:50 AM Mark van den Boogaard <[hidden email]> wrote:
Hello all,

We connect to a AIX version 7 with guacamole using the SSH-protocol. When using the backspace it does not show it on the screen. It will do the actually handling, but it is not shown on the screen. The letter is stil on the screen and the cursor didn't move but when pressing "enter" the letter is not in the action. 
Example running "ls" with typo corrected


When we connect to the same server with guacamole using the Telnet-protocol it is just working fine. When connecting directly without guacamole using the SSH-protocol it is also working fine. 

We prefer SSH because telnet does not automatically log in on this machine and the file-transfer we need.

Does anybody has an idea how to solve this?

-- 
Met vriendelijke groet / with kind regards,

Mark van den Boogaard

--

---

David Landry


unknown-DMPSRY (11K) Download Attachment
unknown-DMPSRY (11K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Problem with backspace on AIX 7

Mark van den Boogaard
Unfortunately I'm not able to reproduce  the problem SSHing directly.

-- 
Met vriendelijke groet / with kind regards,

Mark van den Boogaard
Linux specialist

​​

Mob: +31 6 82241436

Davanti Warehousing B.V.
Hogeweg 35E, Postbus 2601, 5300 CB Zaltbommel

-----Original Message-----
From: David Landry <[hidden email]>
Reply-to: <[hidden email]>
Subject: Re: Problem with backspace on AIX 7
Date: Fri, 09 Dec 2016 13:40:34 +0000

Can you reproduce the problem by SSHing in directly? Without Guacamole?


On Fri, Dec 9, 2016, 4:50 AM Mark van den Boogaard <[hidden email]> wrote:
Hello all,

We connect to a AIX version 7 with guacamole using the SSH-protocol. When using the backspace it does not show it on the screen. It will do the actually handling, but it is not shown on the screen. The letter is stil on the screen and the cursor didn't move but when pressing "enter" the letter is not in the action. 
Example running "ls" with typo corrected


When we connect to the same server with guacamole using the Telnet-protocol it is just working fine. When connecting directly without guacamole using the SSH-protocol it is also working fine. 

We prefer SSH because telnet does not automatically log in on this machine and the file-transfer we need.

Does anybody has an idea how to solve this?

-- 
Met vriendelijke groet / with kind regards,

Mark van den Boogaard


--

---

David Landry

Reply | Threaded
Open this post in threaded view
|

RE: Problem with backspace on AIX 7

Adrian Owen

I just booked an AIX 7.1 LPAR from SiteOX for 24 hours. I can confirm Mark van den Boogaard’s issue:

 

BACKSPACE does not work on Guacamole SSH AIX terminal. Putty is OKAY.

 

 

Mike – I can give you logon details to this AIX LPAR if you want to test it, please let me know ASAP.

 

Kind Regards, Adrian

 

From: Mark van den Boogaard [mailto:[hidden email]]
Sent: 12 December 2016 05:51
To: [hidden email]
Subject: Re: Problem with backspace on AIX 7

 

Unfortunately I'm not able to reproduce  the problem SSHing directly.

 

-- 

Met vriendelijke groet / with kind regards,

 

Mark van den Boogaard

Linux specialist

 

cid:image001.jpg@01D25440.2EE89400​​

 

Mob: +31 6 82241436

 

Davanti Warehousing B.V.

Hogeweg 35E, Postbus 2601, 5300 CB Zaltbommel

 

-----Original Message-----

From: David Landry <[hidden email]>

Reply-to: <[hidden email]>

Subject: Re: Problem with backspace on AIX 7

Date: Fri, 09 Dec 2016 13:40:34 +0000

 

Can you reproduce the problem by SSHing in directly? Without Guacamole?

 

On Fri, Dec 9, 2016, 4:50 AM Mark van den Boogaard <[hidden email]> wrote:

Hello all,

 

We connect to a AIX version 7 with guacamole using the SSH-protocol. When using the backspace it does not show it on the screen. It will do the actually handling, but it is not shown on the screen. The letter is stil on the screen and the cursor didn't move but when pressing "enter" the letter is not in the action. 

Example running "ls" with typo corrected

 

When we connect to the same server with guacamole using the Telnet-protocol it is just working fine. When connecting directly without guacamole using the SSH-protocol it is also working fine. 

 

We prefer SSH because telnet does not automatically log in on this machine and the file-transfer we need.

 

Does anybody has an idea how to solve this?

 

-- 

Met vriendelijke groet / with kind regards,

 

Mark van den Boogaard

 

 

--

---

David Landry


No virus found in this message.
Checked by AVG - www.avg.com
Version: 2016.0.7924 / Virus Database: 4728/13569 - Release Date: 12/10/16

Reply | Threaded
Open this post in threaded view
|

Re: Problem with backspace on AIX 7

Steffen Moser
Hi all,

I don't know if it is related, but the "Delete" key [1] behaves
different on Solaris. This occurs also when being logged in via a plain
SSH from Linux or macOS without having Guacamole involved at all:

http://unix.stackexchange.com/questions/66434/delete-key-doesnt-work-on-command-line

Maybe there is a relation to AIX' behavior.

Kind regards,
Steffen

[1] https://en.wikipedia.org/wiki/Delete_key


On 12/12/16 8:55 AM, Adrian Owen wrote:

> I just booked an AIX 7.1 LPAR from SiteOX for 24 hours. I can confirm
> Mark van den Boogaard’s**issue*:*
>
> * *
>
> BACKSPACE does not work on Guacamole SSH AIX terminal. Putty is OKAY.
>
>  
>
>  
>
> Mike – I can give you logon details to this AIX LPAR if you want to test
> it, please let me know ASAP.
>
>  
>
> Kind Regards, Adrian
>
>  
>
> *From:*Mark van den Boogaard [mailto:[hidden email]]
> *Sent:* 12 December 2016 05:51
> *To:* [hidden email]
> *Subject:* Re: Problem with backspace on AIX 7
>
>  
>
> Unfortunately I'm not able to reproduce  the problem SSHing directly.
>
>  
>
> --
>
> Met vriendelijke groet / with kind regards,
>
>  
>
> *Mark van den Boogaard*
>
> Linux specialist
>
>  
>
> imap://lists%40steffen-moser%[hidden email]:993/fetch%3EUID%3E.INBOX%3E155664?header=quotebody&part=1.2&filename=image001.jpg
> ​​
>
>  
>
> Mob:+31 6 82241436
>
> E-Mail:[hidden email]
> <mailto:[hidden email]>
>
> Web:www.davantigroup.com <http://www.davantigroup.com>
>
>  
>
> *Davanti Warehousing B.V.*
>
> Hogeweg 35E, Postbus 2601, 5300 CB Zaltbommel
>
>  
>
> -----Original Message-----
>
> *From*: David Landry <[hidden email]
> <mailto:David%20Landry%20%[hidden email]%3e>>
>
> Reply-to: <[hidden email]
> <mailto:[hidden email]>>
>
> *To*: [hidden email]
> <mailto:[hidden email]>
> <[hidden email]
> <mailto:%[hidden email]%22%20%[hidden email]%3e>>
>
> *Subject*: Re: Problem with backspace on AIX 7
>
> *Date*: Fri, 09 Dec 2016 13:40:34 +0000
>
>  
>
> Can you reproduce the problem by SSHing in directly? Without Guacamole?
>
>  
>
> On Fri, Dec 9, 2016, 4:50 AM Mark van den Boogaard
> <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     Hello all,
>
>      
>
>     We connect to a AIX version 7 with guacamole using the SSH-protocol.
>     When using the backspace it does not show it on the screen. It will
>     do the actually handling, but it is not shown on the screen. The
>     letter is stil on the screen and the cursor didn't move but when
>     pressing "enter" the letter is not in the action.
>
>     Example running "ls" with typo corrected
>
>     cid:[hidden email]
>
>      
>
>     When we connect to the same server with guacamole using the
>     Telnet-protocol it is just working fine. When connecting directly
>     without guacamole using the SSH-protocol it is also working fine.
>
>      
>
>     We prefer SSH because telnet does not automatically log in on this
>     machine and the file-transfer we need.
>
>      
>
>     Does anybody has an idea how to solve this?
>
>      
>
>     --
>
>     Met vriendelijke groet / with kind regards,
>
>      
>
>     *Mark van den Boogaard*
>
>      
>
>      
>
> --
>
> ---
>
> David Landry
>
> ------------------------------------------------------------------------
>
> No virus found in this message.
> Checked by AVG - www.avg.com <http://www.avg.com>
> Version: 2016.0.7924 / Virus Database: 4728/13569 - Release Date: 12/10/16
>