RDP - First Connection Issue

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

RDP - First Connection Issue

Mehdi Osman
Hi,

We're having a strange issue with Guacamole upon first connection only. Our use case is the following:
1) We create a VM in the cloud (Windows or Linux)
2) As soon as the VM is available, we insert a new "Connection" into the MySQL DB
3) Then, we try to connect

What happens (in like 3 times out of 5) is that we get the connection issue popup asking us to "Reconnect". As soon as we hit the button, we connect successfully. Then, once done the first time, we never face the issue again.

The only workaround we found, is by adding a delay between steps 2) 3) above. The higher the delay (15s) the less chances we face the issue.

It's important to note that we use RDP to connect to Ubuntu (with xRDP) or Windows VMs.

Any idea?

Thanks for your time.
Reply | Threaded
Open this post in threaded view
|

Re: RDP - First Connection Issue

Mehdi Osman
Oh! Forgot to mention that we're using the 0.9.11 version.
Cheers.

2017-03-15 20:07 GMT+01:00 Mehdi Osman <[hidden email]>:
Hi,

We're having a strange issue with Guacamole upon first connection only. Our use case is the following:
1) We create a VM in the cloud (Windows or Linux)
2) As soon as the VM is available, we insert a new "Connection" into the MySQL DB
3) Then, we try to connect

What happens (in like 3 times out of 5) is that we get the connection issue popup asking us to "Reconnect". As soon as we hit the button, we connect successfully. Then, once done the first time, we never face the issue again.

The only workaround we found, is by adding a delay between steps 2) 3) above. The higher the delay (15s) the less chances we face the issue.

It's important to note that we use RDP to connect to Ubuntu (with xRDP) or Windows VMs.

Any idea?

Thanks for your time.



--


Mehdi Osman  
Managing PartnerAC Fellows
m. +33 6 61 38 47 65
Reply | Threaded
Open this post in threaded view
|

Re: RDP - First Connection Issue

Mehdi Osman
Hi Mike,

Any idea on the issue?

Your help is very much appreciated.
Thanks for your support and keep up the good work.



From: Mehdi Osman <[hidden email]>
Sent: Wednesday, March 15, 2017 8:08:03 PM
To: [hidden email]
Subject: Re: RDP - First Connection Issue
 
Oh! Forgot to mention that we're using the 0.9.11 version.
Cheers.

2017-03-15 20:07 GMT+01:00 Mehdi Osman <[hidden email]>:
Hi,

We're having a strange issue with Guacamole upon first connection only. Our use case is the following:
1) We create a VM in the cloud (Windows or Linux)
2) As soon as the VM is available, we insert a new "Connection" into the MySQL DB
3) Then, we try to connect

What happens (in like 3 times out of 5) is that we get the connection issue popup asking us to "Reconnect". As soon as we hit the button, we connect successfully. Then, once done the first time, we never face the issue again.

The only workaround we found, is by adding a delay between steps 2) 3) above. The higher the delay (15s) the less chances we face the issue.

It's important to note that we use RDP to connect to Ubuntu (with xRDP) or Windows VMs.

Any idea?

Thanks for your time.



--


Mehdi Osman  
Managing PartnerAC Fellows
m. +33 6 61 38 47 65
Reply | Threaded
Open this post in threaded view
|

Re: RDP - First Connection Issue

Kris Germann
Do you have any connection logs that you’re able to share with us from the time you click connect?

When it asks you to reconnect, is it successful?

Try turning off NLA.

Kris

On Mar 16, 2017, at 5:49 PM, Mehdi Osman <[hidden email]> wrote:

Hi Mike,

Any idea on the issue?

Your help is very much appreciated.
Thanks for your support and keep up the good work.



From: Mehdi Osman <[hidden email]>
Sent: Wednesday, March 15, 2017 8:08:03 PM
To: [hidden email]
Subject: Re: RDP - First Connection Issue
 
Oh! Forgot to mention that we're using the 0.9.11 version.
Cheers.

2017-03-15 20:07 GMT+01:00 Mehdi Osman <[hidden email]>:
Hi,

We're having a strange issue with Guacamole upon first connection only. Our use case is the following:
1) We create a VM in the cloud (Windows or Linux)
2) As soon as the VM is available, we insert a new "Connection" into the MySQL DB
3) Then, we try to connect

What happens (in like 3 times out of 5) is that we get the connection issue popup asking us to "Reconnect". As soon as we hit the button, we connect successfully. Then, once done the first time, we never face the issue again.

The only workaround we found, is by adding a delay between steps 2) 3) above. The higher the delay (15s) the less chances we face the issue.

It's important to note that we use RDP to connect to Ubuntu (with xRDP) or Windows VMs.

Any idea?

Thanks for your time.



--


Mehdi Osman  
Managing PartnerAC Fellows
m. +33 6 61 38 47 65

Reply | Threaded
Open this post in threaded view
|

Re: RDP - First Connection Issue

Steve Karam
In reply to this post by Mehdi Osman
Mehdi,

Which cloud? It sounds like this could be related to the target systems, not to Guacamole. For example, Windows systems may need an extra reboot when launched from an AMI in EC2 depending on how they were created. Is it possible that the target linux systems are becoming unavailable while they go through init? If you try to connect via native RDP to these systems at the same point as #3 in your steps, does it get disconnected at any point?

In short, if the server hosting the Guacamole client is always available, but the targets are temporarily unavailable post-launch, it seems more likely it’s the targets initializing.

Steve Karam

On Mar 16, 2017, at 5:49 PM, Mehdi Osman <[hidden email]> wrote:

Hi Mike,

Any idea on the issue?

Your help is very much appreciated.
Thanks for your support and keep up the good work.



From: Mehdi Osman <[hidden email]>
Sent: Wednesday, March 15, 2017 8:08:03 PM
To: [hidden email]
Subject: Re: RDP - First Connection Issue
 
Oh! Forgot to mention that we're using the 0.9.11 version.
Cheers.

2017-03-15 20:07 GMT+01:00 Mehdi Osman <[hidden email]>:
Hi,

We're having a strange issue with Guacamole upon first connection only. Our use case is the following:
1) We create a VM in the cloud (Windows or Linux)
2) As soon as the VM is available, we insert a new "Connection" into the MySQL DB
3) Then, we try to connect

What happens (in like 3 times out of 5) is that we get the connection issue popup asking us to "Reconnect". As soon as we hit the button, we connect successfully. Then, once done the first time, we never face the issue again.

The only workaround we found, is by adding a delay between steps 2) 3) above. The higher the delay (15s) the less chances we face the issue.

It's important to note that we use RDP to connect to Ubuntu (with xRDP) or Windows VMs.

Any idea?

Thanks for your time.



--


Mehdi Osman  
Managing PartnerAC Fellows
m. +33 6 61 38 47 65

Reply | Threaded
Open this post in threaded view
|

Re: RDP - First Connection Issue

Mehdi Osman
Hi Steve, Kris,

We're relying on Google Compute Engine. VMs are much much quicker to launch.

On the logs side, there's nothing suspicious. Below is the excerpt when it fails:
Mar 20 08:54:23 guac-gtw-tsq1 guacd[1480]: Creating new client for protocol "rdp"
Mar 20 08:54:23 guac-gtw-tsq1 guacd[1480]: Connection ID is "$9cdb7c0c-9af4-4d74-9c08-3d336cfa9617"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Security mode: ANY
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Parameter "enable-wallpaper" must be either "true" or "false". Using default value.
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Resize method: none
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: User "@56e3b092-c223-4ea4-ad6c-331ae1abc888" joined connection "$9cdb7c0c-9af4-4d74-9c08-3d336cfa9617" (1 users now present)
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Loading keymap "base"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Loading keymap "en-us-qwerty"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Failed to load guacdr plugin. Drive redirection and printing will not work. Sound MAY not work.
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Failed to load guacsnd alongside guacdr plugin. Sound will not work. Drive redirection and printing MAY not work.
Thanks.

2017-03-16 22:53 GMT+01:00 Steve Karam <[hidden email]>:
Mehdi,

Which cloud? It sounds like this could be related to the target systems, not to Guacamole. For example, Windows systems may need an extra reboot when launched from an AMI in EC2 depending on how they were created. Is it possible that the target linux systems are becoming unavailable while they go through init? If you try to connect via native RDP to these systems at the same point as #3 in your steps, does it get disconnected at any point?

In short, if the server hosting the Guacamole client is always available, but the targets are temporarily unavailable post-launch, it seems more likely it’s the targets initializing.

Steve Karam

On Mar 16, 2017, at 5:49 PM, Mehdi Osman <[hidden email]> wrote:

Hi Mike,

Any idea on the issue?

Your help is very much appreciated.
Thanks for your support and keep up the good work.



From: Mehdi Osman <[hidden email]>
Sent: Wednesday, March 15, 2017 8:08:03 PM
To: [hidden email]
Subject: Re: RDP - First Connection Issue
 
Oh! Forgot to mention that we're using the 0.9.11 version.
Cheers.

2017-03-15 20:07 GMT+01:00 Mehdi Osman <[hidden email]>:
Hi,

We're having a strange issue with Guacamole upon first connection only. Our use case is the following:
1) We create a VM in the cloud (Windows or Linux)
2) As soon as the VM is available, we insert a new "Connection" into the MySQL DB
3) Then, we try to connect

What happens (in like 3 times out of 5) is that we get the connection issue popup asking us to "Reconnect". As soon as we hit the button, we connect successfully. Then, once done the first time, we never face the issue again.

The only workaround we found, is by adding a delay between steps 2) 3) above. The higher the delay (15s) the less chances we face the issue.

It's important to note that we use RDP to connect to Ubuntu (with xRDP) or Windows VMs.

Any idea?

Thanks for your time.



--


Mehdi Osman  
Managing PartnerAC Fellows
m. <a href="tel:+33%206%2061%2038%2047%2065" value="+33661384765" target="_blank">+33 6 61 38 47 65




--


Mehdi Osman  
Managing PartnerAC Fellows
m. +33 6 61 38 47 65
Reply | Threaded
Open this post in threaded view
|

Re: RDP - First Connection Issue

Mike Jumper
On Mon, Mar 20, 2017 at 1:57 AM, Mehdi Osman <[hidden email]> wrote:
Hi Steve, Kris,

We're relying on Google Compute Engine. VMs are much much quicker to launch.

On the logs side, there's nothing suspicious. Below is the excerpt when it fails:
Mar 20 08:54:23 guac-gtw-tsq1 guacd[1480]: Creating new client for protocol "rdp"
Mar 20 08:54:23 guac-gtw-tsq1 guacd[1480]: Connection ID is "$9cdb7c0c-9af4-4d74-9c08-3d336cfa9617"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Security mode: ANY
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Parameter "enable-wallpaper" must be either "true" or "false". Using default value.
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Resize method: none
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: User "@56e3b092-c223-4ea4-ad6c-331ae1abc888" joined connection "$9cdb7c0c-9af4-4d74-9c08-3d336cfa9617" (1 users now present)
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Loading keymap "base"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Loading keymap "en-us-qwerty"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Failed to load guacdr plugin. Drive redirection and printing will not work. Sound MAY not work.
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Failed to load guacsnd alongside guacdr plugin. Sound will not work. Drive redirection and printing MAY not work.


Anything else in the logs when this fails?

Those warnings at the bottom are not fatal errors; they're simply warnings that certain functionality is effectively disabled due to guacamole-server's plugins for FreeRDP not being installed to a location where FreeRDP could find them. The RDP connection should still otherwise work fine. If you are ultimately disconnected, there should at least be log messages noting that the connection has closed, and hopefully messages prior to that indicating what error occurred (if any).

- Mike

Reply | Threaded
Open this post in threaded view
|

Re: RDP - First Connection Issue

Mehdi Osman
​Hey Mike,

We spotted the below lines in Catalina.out:
09:48:09.272 [http-nio-8080-exec-12] INFO  o.a.g.tunnel.TunnelRequestService - User "ahmed2" connected to connection "4016".
09:48:24.277 [Thread-2399] ERROR o.a.g.w.GuacamoleWebSocketTunnelEndpoint - Connection to guacd terminated abnormally: Connection to guacd timed out.
09:48:24.277 [Thread-2399] INFO  o.a.g.tunnel.TunnelRequestService - User "ahmed2" disconnected from connection "4016". Duration: 15005 milliseconds

As soon as we hit the "Reconnect" button, it works right away and we never face that issue again, as long as the VM is up & running. We're therefore thinking of removing the delay we added between the time the VM kick starts and connection action, as it's not predictable.

Thanks.

2017-03-20 18:24 GMT+01:00 Mike Jumper <[hidden email]>:
On Mon, Mar 20, 2017 at 1:57 AM, Mehdi Osman <[hidden email]> wrote:
Hi Steve, Kris,

We're relying on Google Compute Engine. VMs are much much quicker to launch.

On the logs side, there's nothing suspicious. Below is the excerpt when it fails:
Mar 20 08:54:23 guac-gtw-tsq1 guacd[1480]: Creating new client for protocol "rdp"
Mar 20 08:54:23 guac-gtw-tsq1 guacd[1480]: Connection ID is "$9cdb7c0c-9af4-4d74-9c08-3d336cfa9617"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Security mode: ANY
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Parameter "enable-wallpaper" must be either "true" or "false". Using default value.
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Resize method: none
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: User "@56e3b092-c223-4ea4-ad6c-331ae1abc888" joined connection "$9cdb7c0c-9af4-4d74-9c08-3d336cfa9617" (1 users now present)
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Loading keymap "base"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Loading keymap "en-us-qwerty"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Failed to load guacdr plugin. Drive redirection and printing will not work. Sound MAY not work.
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Failed to load guacsnd alongside guacdr plugin. Sound will not work. Drive redirection and printing MAY not work.


Anything else in the logs when this fails?

Those warnings at the bottom are not fatal errors; they're simply warnings that certain functionality is effectively disabled due to guacamole-server's plugins for FreeRDP not being installed to a location where FreeRDP could find them. The RDP connection should still otherwise work fine. If you are ultimately disconnected, there should at least be log messages noting that the connection has closed, and hopefully messages prior to that indicating what error occurred (if any).

- Mike




--


Mehdi Osman  
Managing PartnerAC Fellows
m. +33 6 61 38 47 65
Reply | Threaded
Open this post in threaded view
|

Re: RDP - First Connection Issue

Frederico Attoni
Hi Mehdi,

Try to use the ip instead of the vm name. If it works set on the server hosts the name / ip listing.



2017-03-20 14:30 GMT-03:00 Mehdi Osman <[hidden email]>:
​Hey Mike,

We spotted the below lines in Catalina.out:
09:48:09.272 [http-nio-8080-exec-12] INFO  o.a.g.tunnel.TunnelRequestService - User "ahmed2" connected to connection "4016".
09:48:24.277 [Thread-2399] ERROR o.a.g.w.GuacamoleWebSocketTunnelEndpoint - Connection to guacd terminated abnormally: Connection to guacd timed out.
09:48:24.277 [Thread-2399] INFO  o.a.g.tunnel.TunnelRequestService - User "ahmed2" disconnected from connection "4016". Duration: 15005 milliseconds

As soon as we hit the "Reconnect" button, it works right away and we never face that issue again, as long as the VM is up & running. We're therefore thinking of removing the delay we added between the time the VM kick starts and connection action, as it's not predictable.

Thanks.

2017-03-20 18:24 GMT+01:00 Mike Jumper <[hidden email]>:
On Mon, Mar 20, 2017 at 1:57 AM, Mehdi Osman <[hidden email]> wrote:
Hi Steve, Kris,

We're relying on Google Compute Engine. VMs are much much quicker to launch.

On the logs side, there's nothing suspicious. Below is the excerpt when it fails:
Mar 20 08:54:23 guac-gtw-tsq1 guacd[1480]: Creating new client for protocol "rdp"
Mar 20 08:54:23 guac-gtw-tsq1 guacd[1480]: Connection ID is "$9cdb7c0c-9af4-4d74-9c08-3d336cfa9617"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Security mode: ANY
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Parameter "enable-wallpaper" must be either "true" or "false". Using default value.
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Resize method: none
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: User "@56e3b092-c223-4ea4-ad6c-331ae1abc888" joined connection "$9cdb7c0c-9af4-4d74-9c08-3d336cfa9617" (1 users now present)
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Loading keymap "base"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Loading keymap "en-us-qwerty"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Failed to load guacdr plugin. Drive redirection and printing will not work. Sound MAY not work.
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Failed to load guacsnd alongside guacdr plugin. Sound will not work. Drive redirection and printing MAY not work.


Anything else in the logs when this fails?

Those warnings at the bottom are not fatal errors; they're simply warnings that certain functionality is effectively disabled due to guacamole-server's plugins for FreeRDP not being installed to a location where FreeRDP could find them. The RDP connection should still otherwise work fine. If you are ultimately disconnected, there should at least be log messages noting that the connection has closed, and hopefully messages prior to that indicating what error occurred (if any).

- Mike




--


Mehdi Osman  
Managing PartnerAC Fellows
m. +33 6 61 38 47 65

Reply | Threaded
Open this post in threaded view
|

Re: RDP - First Connection Issue

Mehdi Osman
Hi Frederico,

We're already using the IP...

Thanks.

2017-03-20 18:43 GMT+01:00 Frederico Attoni <[hidden email]>:
Hi Mehdi,

Try to use the ip instead of the vm name. If it works set on the server hosts the name / ip listing.



2017-03-20 14:30 GMT-03:00 Mehdi Osman <[hidden email]>:
​Hey Mike,

We spotted the below lines in Catalina.out:
09:48:09.272 [http-nio-8080-exec-12] INFO  o.a.g.tunnel.TunnelRequestService - User "ahmed2" connected to connection "4016".
09:48:24.277 [Thread-2399] ERROR o.a.g.w.GuacamoleWebSocketTunnelEndpoint - Connection to guacd terminated abnormally: Connection to guacd timed out.
09:48:24.277 [Thread-2399] INFO  o.a.g.tunnel.TunnelRequestService - User "ahmed2" disconnected from connection "4016". Duration: 15005 milliseconds

As soon as we hit the "Reconnect" button, it works right away and we never face that issue again, as long as the VM is up & running. We're therefore thinking of removing the delay we added between the time the VM kick starts and connection action, as it's not predictable.

Thanks.

2017-03-20 18:24 GMT+01:00 Mike Jumper <[hidden email]>:
On Mon, Mar 20, 2017 at 1:57 AM, Mehdi Osman <[hidden email]> wrote:
Hi Steve, Kris,

We're relying on Google Compute Engine. VMs are much much quicker to launch.

On the logs side, there's nothing suspicious. Below is the excerpt when it fails:
Mar 20 08:54:23 guac-gtw-tsq1 guacd[1480]: Creating new client for protocol "rdp"
Mar 20 08:54:23 guac-gtw-tsq1 guacd[1480]: Connection ID is "$9cdb7c0c-9af4-4d74-9c08-3d336cfa9617"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Security mode: ANY
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Parameter "enable-wallpaper" must be either "true" or "false". Using default value.
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Resize method: none
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: User "@56e3b092-c223-4ea4-ad6c-331ae1abc888" joined connection "$9cdb7c0c-9af4-4d74-9c08-3d336cfa9617" (1 users now present)
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Loading keymap "base"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Loading keymap "en-us-qwerty"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Failed to load guacdr plugin. Drive redirection and printing will not work. Sound MAY not work.
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Failed to load guacsnd alongside guacdr plugin. Sound will not work. Drive redirection and printing MAY not work.


Anything else in the logs when this fails?

Those warnings at the bottom are not fatal errors; they're simply warnings that certain functionality is effectively disabled due to guacamole-server's plugins for FreeRDP not being installed to a location where FreeRDP could find them. The RDP connection should still otherwise work fine. If you are ultimately disconnected, there should at least be log messages noting that the connection has closed, and hopefully messages prior to that indicating what error occurred (if any).

- Mike




--


Mehdi Osman  
Managing PartnerAC Fellows
m. <a href="tel:+33%206%2061%2038%2047%2065" value="+33661384765" target="_blank">+33 6 61 38 47 65




--


Mehdi Osman  
Managing PartnerAC Fellows
m. +33 6 61 38 47 65
Reply | Threaded
Open this post in threaded view
|

Re: RDP - First Connection Issue

Mehdi Osman
Hi Mike,

Any idea on this issue? We've tried many workarounds with no luck.

Thanks a lot.

2017-03-20 18:53 GMT+01:00 Mehdi Osman <[hidden email]>:
Hi Frederico,

We're already using the IP...

Thanks.

2017-03-20 18:43 GMT+01:00 Frederico Attoni <[hidden email]>:
Hi Mehdi,

Try to use the ip instead of the vm name. If it works set on the server hosts the name / ip listing.



2017-03-20 14:30 GMT-03:00 Mehdi Osman <[hidden email]>:
​Hey Mike,

We spotted the below lines in Catalina.out:
09:48:09.272 [http-nio-8080-exec-12] INFO  o.a.g.tunnel.TunnelRequestService - User "ahmed2" connected to connection "4016".
09:48:24.277 [Thread-2399] ERROR o.a.g.w.GuacamoleWebSocketTunnelEndpoint - Connection to guacd terminated abnormally: Connection to guacd timed out.
09:48:24.277 [Thread-2399] INFO  o.a.g.tunnel.TunnelRequestService - User "ahmed2" disconnected from connection "4016". Duration: 15005 milliseconds

As soon as we hit the "Reconnect" button, it works right away and we never face that issue again, as long as the VM is up & running. We're therefore thinking of removing the delay we added between the time the VM kick starts and connection action, as it's not predictable.

Thanks.

2017-03-20 18:24 GMT+01:00 Mike Jumper <[hidden email]>:
On Mon, Mar 20, 2017 at 1:57 AM, Mehdi Osman <[hidden email]> wrote:
Hi Steve, Kris,

We're relying on Google Compute Engine. VMs are much much quicker to launch.

On the logs side, there's nothing suspicious. Below is the excerpt when it fails:
Mar 20 08:54:23 guac-gtw-tsq1 guacd[1480]: Creating new client for protocol "rdp"
Mar 20 08:54:23 guac-gtw-tsq1 guacd[1480]: Connection ID is "$9cdb7c0c-9af4-4d74-9c08-3d336cfa9617"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Security mode: ANY
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Parameter "enable-wallpaper" must be either "true" or "false". Using default value.
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Resize method: none
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: User "@56e3b092-c223-4ea4-ad6c-331ae1abc888" joined connection "$9cdb7c0c-9af4-4d74-9c08-3d336cfa9617" (1 users now present)
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Loading keymap "base"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Loading keymap "en-us-qwerty"
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Failed to load guacdr plugin. Drive redirection and printing will not work. Sound MAY not work.
Mar 20 08:54:24 guac-gtw-tsq1 guacd[15570]: Failed to load guacsnd alongside guacdr plugin. Sound will not work. Drive redirection and printing MAY not work.


Anything else in the logs when this fails?

Those warnings at the bottom are not fatal errors; they're simply warnings that certain functionality is effectively disabled due to guacamole-server's plugins for FreeRDP not being installed to a location where FreeRDP could find them. The RDP connection should still otherwise work fine. If you are ultimately disconnected, there should at least be log messages noting that the connection has closed, and hopefully messages prior to that indicating what error occurred (if any).

- Mike




--


Mehdi Osman  
Managing PartnerAC Fellows
m. <a href="tel:+33%206%2061%2038%2047%2065" value="+33661384765" target="_blank">+33 6 61 38 47 65




--


Mehdi Osman  
Managing PartnerAC Fellows
m. <a href="tel:+33%206%2061%2038%2047%2065" value="+33661384765" target="_blank">+33 6 61 38 47 65

Reply | Threaded
Open this post in threaded view
|

Re: RDP - First Connection Issue

Mike Jumper
On Mon, Mar 27, 2017 at 8:17 AM, Mehdi Osman <[hidden email]> wrote:
Hi Mike,

Any idea on this issue? We've tried many workarounds with no luck.

Only that you should continue to look into whether the RDP service on the machine in question (as well as the machine itself) is fully up and available at the time that the connection attempt is made.

There isn't anything in Guacamole itself which would lead to this sort of behavior, where the first connection attempt fails, but subsequent attempts succeed. Each attempt is really identical to any other. The most likely explanation given the circumstances is that the RDP service is simply not available at the time the connection attempt was made, but becomes available in time for the other attempts.

- Mike

Reply | Threaded
Open this post in threaded view
|

Re: RDP - First Connection Issue

Der PCFreak

On 28.03.2017 05:13, Mike Jumper wrote:
On Mon, Mar 27, 2017 at 8:17 AM, Mehdi Osman <[hidden email]> wrote:
Hi Mike,

Any idea on this issue? We've tried many workarounds with no luck.

Only that you should continue to look into whether the RDP service on the machine in question (as well as the machine itself) is fully up and available at the time that the connection attempt is made.

There isn't anything in Guacamole itself which would lead to this sort of behavior, where the first connection attempt fails, but subsequent attempts succeed. Each attempt is really identical to any other. The most likely explanation given the circumstances is that the RDP service is simply not available at the time the connection attempt was made, but becomes available in time for the other attempts.

- Mike

could it be so simple, that the RDP server has a session limit in place?

- Peter