[RDP] NLA Authentification fails with username who contains some characters

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[RDP] NLA Authentification fails with username who contains some characters

cbosys
This post was updated on .
I'm currently trying to use guacamole with NLA Authentification in RDP.
It works with users who has username that contain standarts characters
(A-Z/a-z..), but when i try to connect with users who username contains "é",
"è", "Ü", "ç", "à"... characters (like "André"), i've got the error "Error
connecting to RDP Server" in syslog and i can see that the NLA
authentification failed on my server event viewer.
When i try "Andre" instead of "André", it works (AD usernames aren't case
sensitive), and if i try to connect with "André" WITHOUT NLA
Authentification, it also works.

This doesn't seems to be a FreeRDP issue, i tried NLA authentification
directly with FreeRDP (branch stable.1-1) and it works.

Reply | Threaded
Open this post in threaded view
|

Re: [RDP] NLA Authentification fails with username who contains some characters

vnick


On Wed, Oct 11, 2017 at 8:54 AM, cbosys <[hidden email]> wrote:
*Guacamole server 0.9.11-incubating*
*Guacamole client 0.9.11*

Can you try 0.9.13-incubating (the latest) and see if the issue still exists there?

-Nick
Reply | Threaded
Open this post in threaded view
|

Re: [RDP] NLA Authentification fails with username who contains some characters

cbosys
I have tested with version 0.9.13 also, i have the same issue.



--
Sent from: http://apache-guacamole-incubating-users.2363388.n4.nabble.com/