Sound over RDP issue (with solution)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Sound over RDP issue (with solution)

Rhys Ferris

Hello everyone,

 

Absolutely love Guacamole, been using 0.9.14 for about a year, but the sound never worked with RDP. Finally got tired of it and check to see if there was an update. Sure enough. I installed 1.0.0 from source on a fresh VM, following the directions in the manual. Still, no sound, though now at least the remote machine recognized something; no red “X” in the speaker, but no sound either. Found this old post suggesting the creation of symbolic links: https://sourceforge.net/p/guacamole/discussion/1110834/thread/dc311c34/ . This worked with slight modification:

(obviously) Required the creation of directory /usr/lib/x86_64-linux-gnu/freerdp/

sudo ln -s /usr/local/lib/freerdp/guacsnd-client.so /usr/lib/x86_64-linux-gnu/freerdp/
sudo ln -s /usr/local/lib/freerdp/guacdr-client.so /usr/lib/x86_64-linux-gnu/freerdp/

And POOF, audio.

I’m hoping this info can make its way to the correct people so that perhaps this can be taken to the point where the above is no longer required, or perhaps it will help someone else.

Details on my setup:

Guacamole running on Ubuntu Server 18.0.4 as a VM running on KVM on Ubuntu Server 18.0.4

Remote Machine: Win10 1809 as a VM on KVM on Ubuntu Server 18.0.4

Client: Win10 1809 physical laptop using Firefox – current version.

 

Let me know if there’s any other info that would help.

Rhys

Reply | Threaded
Open this post in threaded view
|

Re: Sound over RDP issue (with solution)

vnick
On Sat, Feb 2, 2019 at 12:43 PM <[hidden email]> wrote:

Hello everyone,

 

Absolutely love Guacamole, been using 0.9.14 for about a year, but the sound never worked with RDP. Finally got tired of it and check to see if there was an update. Sure enough. I installed 1.0.0 from source on a fresh VM, following the directions in the manual. Still, no sound, though now at least the remote machine recognized something; no red “X” in the speaker, but no sound either. Found this old post suggesting the creation of symbolic links: https://sourceforge.net/p/guacamole/discussion/1110834/thread/dc311c34/ . This worked with slight modification:

(obviously) Required the creation of directory /usr/lib/x86_64-linux-gnu/freerdp/

sudo ln -s /usr/local/lib/freerdp/guacsnd-client.so /usr/lib/x86_64-linux-gnu/freerdp/
sudo ln -s /usr/local/lib/freerdp/guacdr-client.so /usr/lib/x86_64-linux-gnu/freerdp/

And POOF, audio.

I’m hoping this info can make its way to the correct people so that perhaps this can be taken to the point where the above is no longer required, or perhaps it will help someone else.


Thanks for posting this solution.  This is something that has come up a few times in the past, so probably something we should make sure is either in the Install instructions or the FAQ.

-Nick