Troubleshooting VNC to macOS

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Troubleshooting VNC to macOS

Matt Fusfield
I have Guacamole running on a raspberry PI 4 with a VNC connection to my Mac.

This worked reasonably well until I recently upgraded to 1.2.0. (in fairness, I did not test the connection just before upgrading, but have used it recently otherwise)

Now, whenever I try to connect to the Mac, I get "The Remote Desktop server is currently unreachable" and it retries a few times before giving up. In syslog, I see "guacd[880]: VNC connection failed: Authentication or authorization failure"

On the Mac side, I have screen sharing enabled with a VNC password. I also tried changing to remote management, and double checked the VNC password. Screen sharing from another Mac or an iOS device works just fine. I have a few other SSH connections configured on Guacamole, and that works fine.

Appreciate any ideas on how to further troubleshoot this.