Virtual Drive not mouting in 0.9.11 incubating

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Virtual Drive not mouting in 0.9.11 incubating

Mathieu AYELA

Hi everyone,


I'm building a 0.9.11 incubating Guacamole server but I can't mount virtual drive in RDP connexions.

A few months ago, I've run some tests on a 0.9.9 and it was fully fonctionnal. Last week, I upgraded this server to 0.9.11 and I can't make it work again...


My server is a CentOS 7 up to date, 2 vcpu + 2 go ram.


There is some syslogs event :

Mar  7 10:33:54 svu-inf-guam1 guacd[3349]: Creating new client for protocol "rdp"
Mar  7 10:33:54 svu-inf-guam1 guacd[3349]: Connection ID is "$0ebc3208-55fa-44c8-8d9e-26b2f90997bb"
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Security mode: TLS
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Resize method: none
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: User "@8d347340-ca99-45df-83e5-896af8e472eb" joined connection "$0ebc3208-55fa-44c8-8d9e-26b2f90997bb" (1 users now present)
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Loading keymap "base"
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Loading keymap "fr-fr-azerty"
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: guacdr connected.
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: guacsnd connected.
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Connected to RDPDR 1.12 as client 0x002b
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Ignoring server capability set type=0x0001, length=44
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Ignoring server capability set type=0x0002, length=8
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Ignoring server capability set type=0x0003, length=8
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Ignoring server capability set type=0x0004, length=8
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Ignoring server capability set type=0x0005, length=8
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Sending capabilities...
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Capabilities sent.
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Client ID confirmed
Mar  7 10:34:17 svu-inf-guam1 guacd[16993]: User logged on
Mar  7 10:34:17 svu-inf-guam1 guacd[16993]: All supported devices sent.
Mar  7 10:35:30 svu-inf-guam1 guacd[16993]: RDP server closed connection
Mar  7 10:35:30 svu-inf-guam1 guacd[16993]: User "@8d347340-ca99-45df-83e5-896af8e472eb" disconnected (0 users remain)
Mar  7 10:35:30 svu-inf-guam1 guacd[16993]: Last user of connection "$0ebc3208-55fa-44c8-8d9e-26b2f90997bb" disconnected
Mar  7 10:35:30 svu-inf-guam1 guacd[3349]: Connection "$0ebc3208-55fa-44c8-8d9e-26b2f90997bb" removed.


There is no errors in it, so I don't understand why the virtual drive wouldn't mount.


If anyone has a clue, it will appreciated.

Thank you in advance.


-----------------------

Cordialement,

Mathieu AYELA

Reply | Threaded
Open this post in threaded view
|

RE: Virtual Drive not mouting in 0.9.11 incubating

Mathieu AYELA

Hi,


I've managed to solve my problem.

I forgot to copy guac*.so libs after the upgrade...

Once the new one have been copied, virtual drive mount.


It works better when you go through the all upgrade and don't forgot some steps... ^_^


-----------------------

Cordialement,

Mathieu AYELA
Administrateur Systèmes & Réseaux - DOCAPOST Applicam

DOCAPOST Grands-Comptes / ETI 

1474893219812_logo_docapost-applicam.png

2 Avenue Sébastopol - BP 65052 - 57072 Metz Cedex 3 - France

Tél. : +33 (0)825 120 555 - [hidden email][hidden email]

www.docapost-applicam.fr

1474277066889_docapost_twitter.jpg 1474277094208_docapost_linkedin.png 1474277128753_docapost_youtube.png 1474277145220_docapost_slideshare.png

DOCAPOST est une filiale du Groupe La Poste
Adoptez l'éco-attitude : n'imprimez que si cela vous semble vraiment nécessaire





De : Mathieu AYELA <[hidden email]>
Envoyé : mardi 7 mars 2017 11:40
À : [hidden email]
Objet : Virtual Drive not mouting in 0.9.11 incubating
 

Hi everyone,


I'm building a 0.9.11 incubating Guacamole server but I can't mount virtual drive in RDP connexions.

A few months ago, I've run some tests on a 0.9.9 and it was fully fonctionnal. Last week, I upgraded this server to 0.9.11 and I can't make it work again...


My server is a CentOS 7 up to date, 2 vcpu + 2 go ram.


There is some syslogs event :

Mar  7 10:33:54 svu-inf-guam1 guacd[3349]: Creating new client for protocol "rdp"
Mar  7 10:33:54 svu-inf-guam1 guacd[3349]: Connection ID is "$0ebc3208-55fa-44c8-8d9e-26b2f90997bb"
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Security mode: TLS
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Resize method: none
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: User "@8d347340-ca99-45df-83e5-896af8e472eb" joined connection "$0ebc3208-55fa-44c8-8d9e-26b2f90997bb" (1 users now present)
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Loading keymap "base"
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Loading keymap "fr-fr-azerty"
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: guacdr connected.
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: guacsnd connected.
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Connected to RDPDR 1.12 as client 0x002b
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Ignoring server capability set type=0x0001, length=44
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Ignoring server capability set type=0x0002, length=8
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Ignoring server capability set type=0x0003, length=8
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Ignoring server capability set type=0x0004, length=8
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Ignoring server capability set type=0x0005, length=8
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Sending capabilities...
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Capabilities sent.
Mar  7 10:33:54 svu-inf-guam1 guacd[16993]: Client ID confirmed
Mar  7 10:34:17 svu-inf-guam1 guacd[16993]: User logged on
Mar  7 10:34:17 svu-inf-guam1 guacd[16993]: All supported devices sent.
Mar  7 10:35:30 svu-inf-guam1 guacd[16993]: RDP server closed connection
Mar  7 10:35:30 svu-inf-guam1 guacd[16993]: User "@8d347340-ca99-45df-83e5-896af8e472eb" disconnected (0 users remain)
Mar  7 10:35:30 svu-inf-guam1 guacd[16993]: Last user of connection "$0ebc3208-55fa-44c8-8d9e-26b2f90997bb" disconnected
Mar  7 10:35:30 svu-inf-guam1 guacd[3349]: Connection "$0ebc3208-55fa-44c8-8d9e-26b2f90997bb" removed.


There is no errors in it, so I don't understand why the virtual drive wouldn't mount.


If anyone has a clue, it will appreciated.

Thank you in advance.


-----------------------

Cordialement,

Mathieu AYELA