issue with vim cut/paste via ssh

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

issue with vim cut/paste via ssh

Raz Baluchi
I have a strange issue with copy/paste in vim via an ssh session. If I select a block of text that  I've recently typed in via the mouse (not using visual mode but rather the default clipboard) and then paste that text, all spaces are lost. For example, typing "hello again" and then copying pasting via right clicking the mouse, it pastes as "helloagain".

This issue only occurs with text that was typed while in the current vim session. Existing text in a file can be cut/pasted without issues. The issue also does not happen in nano or emacs, or even vim tiny.

Any ideas?
Reply | Threaded
Open this post in threaded view
|

Re: issue with vim cut/paste via ssh

Paul Cantle
I'm using guacamole 0.9.10 and I have just tested this and confirm the same issue. 

I suspect a JIRA will need to be raised to ask one of the Devs to look at it unless there's a known fix

Cheers





On Tue, Feb 28, 2017 at 3:41 PM +0000, "Raz Baluchi" <[hidden email]> wrote:

I have a strange issue with copy/paste in vim via an ssh session. If I select a block of text that  I've recently typed in via the mouse (not using visual mode but rather the default clipboard) and then paste that text, all spaces are lost. For example, typing "hello again" and then copying pasting via right clicking the mouse, it pastes as "helloagain".

This issue only occurs with text that was typed while in the current vim session. Existing text in a file can be cut/pasted without issues. The issue also does not happen in nano or emacs, or even vim tiny.

Any ideas?